package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\bis:(Foo|Bar)\b.*`)
var str = `"is:Baz is:Foo FooBar" # Captures "Foo"
"is:Foo FooBar is:Bar" # Captures "Bar"
"is:Bar FooBar FooBaz Baz" # Captures "Bar"
"FooBar is:Bar FooBaz" # Captures "Bar"
"FooBar is:Xyzzy is:Foo" # Captures "Foo
"is:Baz FooBar is:Foo" # Captures "Foo"
"FooBar is:Foo is:Xyzzy" # No capture`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}