using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<={LOOP})\s*(.*?)(?={ENDLOOP})";
string input = @"{LOOP}<option value=""%SEL-VL%"">%SEL-TXT%</option>{ENDLOOP}
{LOOP}
<span>Name %s</span>
{ENDLOOP}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}