import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\{LOOP\\})\\s*(.*?)(?=\\{ENDLOOP\\})";
final String string = "{LOOP}<option value=\"%SEL-VL%\">%SEL-TXT%</option>{ENDLOOP}\n\n"
+ "{LOOP}\n"
+ " <span>Name %s</span>\n"
+ "{ENDLOOP}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}