$re = '/(?<={LOOP})\s*(.*?)(?={ENDLOOP})/ms';
$str = '{LOOP}<option value="%SEL-VL%">%SEL-TXT%</option>{ENDLOOP}
{LOOP}
<span>Name %s</span>
{ENDLOOP}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);