import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https|ftp):\\/\\/(\\S*)";
final String string = "The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com , which is also matching";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}