$re = '/(http|https|ftp):\/\/(\S*)/i';
$str = 'The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com , which is also matching';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);