re = /(http|https|ftp):\/\/(\S*)/i
str = 'The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com , which is also matching'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end