use strict;
my $str = '
NPEB00128NPEB00128
NPUB30069NPUB30069
Digital (PSN)Zombie Apocalypse
Playable
2021-07-10 #10526
NPEB00576NPEB00576
Digital (PSN)Zombie Apocalypse: Never Die Alone
Playable
2020-01-27 #7326
NPUB30506NPUB30506
Digital (PSN)Zombie Apocalypse: Never Die Alone Demo
Playable
2018-04-14 #4440
NPEB00811NPEB00811
NPJB00176NPJB00176
NPUB30922NPUB30922
Digital (PSN)Zombie Driver HD
Playable
2018-04-25 #4422
NPUB30859NPUB30859
Digital (PSN)Zombie Tycoon 2 Brainhov Revenge
Playable
2018-12-06 #5400
NPUA30003NPUA30003
Digital (PSN)Zuma
Playable
2018-08-19 #5002
NPEB01160NPEB01160
NPUB30881NPUB30881
Digital (PSN)Zuma\'s Revenge!
Playable
2018-08-16 #4991';
my $regex = qr/(?<=N\)|(?<=Ray)).*(?=)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}