# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=N\)|(?<=Ray)).*(?=)"
test_str = ("\n"
"NPEB00128NPEB00128\n"
"NPUB30069NPUB30069\n"
"Digital (PSN)Zombie Apocalypse\n"
"Playable\n"
"2021-07-10 #10526\n"
"NPEB00576NPEB00576\n"
"Digital (PSN)Zombie Apocalypse: Never Die Alone\n"
"Playable\n"
"2020-01-27 #7326\n"
"NPUB30506NPUB30506\n"
"Digital (PSN)Zombie Apocalypse: Never Die Alone Demo\n"
"Playable\n"
"2018-04-14 #4440\n"
"NPEB00811NPEB00811\n"
"NPJB00176NPJB00176\n"
"NPUB30922NPUB30922\n"
"Digital (PSN)Zombie Driver HD\n"
"Playable\n"
"2018-04-25 #4422\n"
"NPUB30859NPUB30859\n"
"Digital (PSN)Zombie Tycoon 2 Brainhov Revenge\n"
"Playable\n"
"2018-12-06 #5400\n"
"NPUA30003NPUA30003\n"
"Digital (PSN)Zuma\n"
"Playable\n"
"2018-08-19 #5002\n"
"NPEB01160NPEB01160\n"
"NPUB30881NPUB30881\n"
"Digital (PSN)Zuma's Revenge!\n"
"Playable\n"
"2018-08-16 #4991")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.