import Foundation
let pattern = #"(?<=N\)|(?<=Ray)).*(?=)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
NPEB00128NPEB00128
NPUB30069NPUB30069
Digital (PSN)Zombie Apocalypse
Playable
2021-07-10   #10526
NPEB00576NPEB00576
Digital (PSN)Zombie Apocalypse: Never Die Alone
Playable
2020-01-27   #7326
NPUB30506NPUB30506
Digital (PSN)Zombie Apocalypse: Never Die Alone Demo
Playable
2018-04-14   #4440
NPEB00811NPEB00811
NPJB00176NPJB00176
NPUB30922NPUB30922
Digital (PSN)Zombie Driver HD
Playable
2018-04-25   #4422
NPUB30859NPUB30859
Digital (PSN)Zombie Tycoon 2 Brainhov Revenge
Playable
2018-12-06   #5400
NPUA30003NPUA30003
Digital (PSN)Zuma
Playable
2018-08-19   #5002
NPEB01160NPEB01160
NPUB30881NPUB30881
Digital (PSN)Zuma's Revenge!
Playable
2018-08-16   #4991
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)