#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+,\s*f\s*\.\s*\d\s*\d\s*-\s*\d\s*\d\s*-\s*\d\s*\d\s*\d\s*\d"
Local $sString = "Smith, John," & @CRLF & _
"" & @CRLF & _
"f. 25-12-1990" & @CRLF & _
"" & @CRLF & _
"or only first part of below:" & @CRLF & _
"" & @CRLF & _
"Smith, John, f. 25-12-" & @CRLF & _
"" & @CRLF & _
"1990" & @CRLF & _
"" & @CRLF & _
"Smith, John, f. 25-" & @CRLF & _
"" & @CRLF & _
"12-1990"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")