import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+,\\s*f\\s*\\.\\s*\\d\\s*\\d\\s*-\\s*\\d\\s*\\d\\s*-\\s*\\d\\s*\\d\\s*\\d\\s*\\d";
final String string = "Smith, John,\n\n"
+ "f. 25-12-1990\n\n"
+ "or only first part of below:\n\n"
+ "Smith, John, f. 25-12-\n\n"
+ "1990\n\n"
+ "Smith, John, f. 25-\n\n"
+ "12-1990";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}