package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<t>.*?)(__(?<u>.*?))?(__(?<v>[^=]*))?=(?<value>.*)`)
var str = `AppSettings__Envionment__Other=Dev`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}