re = /(?<t>.*?)(__(?<u>.*?))?(__(?<v>[^=]*))?=(?<value>.*)/m
str = 'AppSettings__Envionment__Other=Dev'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end