$re = '/(?<t>.*?)(__(?<u>.*?))?(__(?<v>[^=]*))?=(?<value>.*)/m';
$str = 'AppSettings__Envionment__Other=Dev';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);