package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z].[A-Z]\d+.SFR$)|([A-Z].[A-Z][0-9]\d+.SFR$)|([A-Z].[A-Z][0-9]\d+[A-Z].SFR$)|([A-Z].[A-Z]*[0-9]\d+ -.SFR$)`)
var str = `1468 SFR-PHOTO_000-€
CAP- 1235 SFR1-
C-Z01434-SFR- PHOTO 000-
C-Z01468-SFR
SN- 1468 --SFR•+-CE•-•Request-for-approval
PAC-X0123 SFR-
B-00123•- Invoice for ABC
C-925303-SFR-
C-L25254-SFR
C-LP1122 SFR-
A-123456 SFR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}