const regex = /([A-Z].[A-Z]\d+.SFR$)|([A-Z].[A-Z][0-9]\d+.SFR$)|([A-Z].[A-Z][0-9]\d+[A-Z].SFR$)|([A-Z].[A-Z]*[0-9]\d+ -.SFR$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z].[A-Z]\\d+.SFR$)|([A-Z].[A-Z][0-9]\\d+.SFR$)|([A-Z].[A-Z][0-9]\\d+[A-Z].SFR$)|([A-Z].[A-Z]*[0-9]\\d+ -.SFR$)', 'gm')
const str = `1468 SFR-PHOTO_000-€
CAP- 1235 SFR1-
C-Z01434-SFR- PHOTO 000-
C-Z01468-SFR
SN- 1468 --SFR•+-CE•-•Request-for-approval
PAC-X0123 SFR-
B-00123•- Invoice for ABC
C-925303-SFR-
C-L25254-SFR
C-LP1122 SFR-
A-123456 SFR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}