import Foundation
let pattern = #"([A-Z].[A-Z]\d+.SFR$)|([A-Z].[A-Z][0-9]\d+.SFR$)|([A-Z].[A-Z][0-9]\d+[A-Z].SFR$)|([A-Z].[A-Z]*[0-9]\d+ -.SFR$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1468 SFR-PHOTO_000-€
CAP- 1235 SFR1-
C-Z01434-SFR- PHOTO 000-
C-Z01468-SFR
SN- 1468 --SFR•+-CE•-•Request-for-approval
PAC-X0123 SFR-
B-00123•- Invoice for ABC
C-925303-SFR-
C-L25254-SFR
C-LP1122 SFR-
A-123456 SFR
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)