import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(\\d+\\.([1-9]{3}|[1-9]{2}|[1-9]|0{1}))(\\d*)";
        final String string = "#提取有效小数的思路:匹配出符合要求的组合不符合要求的组。\n"
	 + "#使用sub函数,re.sub(pat,lambda m:m[1],s)\n"
	 + "#repl使用函数,传递的参数是pat,所匹配的match对象,提取match对象中符合要求的组即可。\n"
	 + "124.1230000012\n"
	 + "124.1200003412\n"
	 + "123.0000000012\n"
	 + "1.2000\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}