// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+\.([1-9]{3}|[1-9]{2}|[1-9]|0{1}))(\d*)").unwrap();
let string = "#提取有效小数的思路:匹配出符合要求的组合不符合要求的组。
#使用sub函数,re.sub(pat,lambda m:m[1],s)
#repl使用函数,传递的参数是pat,所匹配的match对象,提取match对象中符合要求的组即可。
124.1230000012
124.1200003412
123.0000000012
1.2000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}