using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{2}\d{2} ?\d{4} ?\d{4} ?\d{4} ?\d{4} ?[\d]{0,2}";
string input = @"DE89 3704 0044 0532 0130 00 DE89370400440532013000
AT61 1904 3002 3457 3201 AT611904300234573201
FR14 2004 1010 0505 0001 3 FR1420041010050500013";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}