// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]{2}\d{2} ?\d{4} ?\d{4} ?\d{4} ?\d{4} ?[\d]{0,2}").unwrap();
let string = "DE89 3704 0044 0532 0130 00 DE89370400440532013000
AT61 1904 3002 3457 3201 AT611904300234573201
FR14 2004 1010 0505 0001 3 FR1420041010050500013";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}