$re = '/[A-Z]{2}\d{2} ?\d{4} ?\d{4} ?\d{4} ?\d{4} ?[\d]{0,2}/m';
$str = 'DE89 3704 0044 0532 0130 00 DE89370400440532013000
AT61 1904 3002 3457 3201 AT611904300234573201
FR14 2004 1010 0505 0001 3 FR1420041010050500013';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);