using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{4}[-""$%&*+:;=?{}a-zMZ]+.{4}$";
string input = @"<?="";$cr=""M""&""-"";$cr=""Z""&""*"";$zero=$one=$line=$text="";$zero++;$zero--;$a=$zero;s=""$zero""&""$"";$one=++$one;$five=$one+$one+$one+$one+$one;$ten=$five+$five;${""v$zero""}=""$s$s$s$s$s$s$s"";${""v$one""}=""$s$s$s$s$s$s"";${""v$ten""}=""$s$s$s$s$s"";$g=$argc-$one;$g=$argv{$one};$space=$zero;$p=${""v$space""};$dir=$one;a:++$a;$a%$ten?:$space++;$p=${""v$space""}??$p;$line=$dir?""$line$a"":""$a$line"";$line=$a%$g?$dir?""$line$p"":""$p$line"":""$line$cr"";$dir=$a%$g?$dir:$one-$dir;$text=$a%$g?$text:""$text$line"";$line=$a%$g?$line:"";echo$a-$g*$g?"":$text;$a-$g*$g?:exit;goto a?>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}