const regex = /^.{4}[-"$%&*+:;=?{}a-zMZ]+.{4}$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{4}[-"$%&*+:;=?{}a-zMZ]+.{4}$', 's')
const str = `<?="";\$cr="M"&"-";\$cr="Z"&"*";\$zero=\$one=\$line=\$text="";\$zero++;\$zero--;\$a=\$zero;s="\$zero"&"\$";\$one=++\$one;\$five=\$one+\$one+\$one+\$one+\$one;\$ten=\$five+\$five;\${"v\$zero"}="\$s\$s\$s\$s\$s\$s\$s";\${"v\$one"}="\$s\$s\$s\$s\$s\$s";\${"v\$ten"}="\$s\$s\$s\$s\$s";\$g=\$argc-\$one;\$g=\$argv{\$one};\$space=\$zero;\$p=\${"v\$space"};\$dir=\$one;a:++\$a;\$a%\$ten?:\$space++;\$p=\${"v\$space"}??\$p;\$line=\$dir?"\$line\$a":"\$a\$line";\$line=\$a%\$g?\$dir?"\$line\$p":"\$p\$line":"\$line\$cr";\$dir=\$a%\$g?\$dir:\$one-\$dir;\$text=\$a%\$g?\$text:"\$text\$line";\$line=\$a%\$g?\$line:"";echo\$a-\$g*\$g?"":\$text;\$a-\$g*\$g?:exit;goto a?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}