$re = '/^.{4}[-"$%&*+:;=?{}a-zMZ]+.{4}$/s';
$str = '<?="";$cr="M"&"-";$cr="Z"&"*";$zero=$one=$line=$text="";$zero++;$zero--;$a=$zero;s="$zero"&"$";$one=++$one;$five=$one+$one+$one+$one+$one;$ten=$five+$five;${"v$zero"}="$s$s$s$s$s$s$s";${"v$one"}="$s$s$s$s$s$s";${"v$ten"}="$s$s$s$s$s";$g=$argc-$one;$g=$argv{$one};$space=$zero;$p=${"v$space"};$dir=$one;a:++$a;$a%$ten?:$space++;$p=${"v$space"}??$p;$line=$dir?"$line$a":"$a$line";$line=$a%$g?$dir?"$line$p":"$p$line":"$line$cr";$dir=$a%$g?$dir:$one-$dir;$text=$a%$g?$text:"$text$line";$line=$a%$g?$line:"";echo$a-$g*$g?"":$text;$a-$g*$g?:exit;goto a?>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);