using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(([^\0-\x19""\\]|\\[^\0-\x19])*)""";
string input = @"const foo = ""say \""foo\"";
const bar = ""hello!"";";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}