$re = '/"(([^\0-\x19"\\\\]|\\\\[^\0-\x19])*)"/';
$str = 'const foo = "say \\"foo\\"";
const bar = "hello!";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);