re = /"(([^\0-\x19"\\]|\\[^\0-\x19])*)"/
str = 'const foo = "say \\"foo\\"";
const bar = "hello!";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end