using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<x_hello_abc>\d+\.\d+\.\d+\.\d+)";
string input = @"""x-hello-abc"":[""101.2.10.1, 102.3.4.3, 12.3.45.5""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}