re = /(?<x_hello_abc>\d+\.\d+\.\d+\.\d+)/m
str = '"x-hello-abc":["101.2.10.1, 102.3.4.3, 12.3.45.5"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end