const regex = /.*(?=\bbet\b).*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(?=\\bbet\\b).*', 'gmi')
const str = `I bet he's a virgin!
Bet you're glad you flew out there.
I betty he's a virgin!
Betty you're glad you flew out there.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}