import re
regex = re.compile(r".*(?=\bbet\b).*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("I bet he's a virgin!\n"
"Bet you're glad you flew out there.\n"
"I betty he's a virgin!\n"
"Betty you're glad you flew out there.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")