re = /.*(?=\bbet\b).*/mi
str = 'I bet he\'s a virgin!
Bet you\'re glad you flew out there.
I betty he\'s a virgin!
Betty you\'re glad you flew out there.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end