use strict;
my $str = 'CREATE TABLE [Company](
[CompanyName] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Address1] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Address2] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[City] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[State] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Zip] [numeric](18, 0) NOT NULL
) ON [PRIMARY]
GO
GO
SET ANSI_PADDING ON
GO
CREATE NONCLUSTERED INDEX [IX_Company] ON [Company]
(
[CompanyName] ASC
)WITH (PAD_INDEX = OFF, STATISTICS_NORECOMPUTE = OFF, SORT_IN_TEMPDB = OFF, DROP_EXISTING = OFF, ONLINE = OFF, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON, FILLFACTOR = 80) ON [PRIMARY]
GO
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_CompanyName] DEFAULT (\'\') FOR [CompanyName]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Address1] DEFAULT (\'\') FOR [Address1]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Address2] DEFAULT (\'\') FOR [Address2]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_City] DEFAULT (\'\') FOR [City]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_State] DEFAULT (\'\') FOR [State]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Zip] DEFAULT ((0)) FOR [Zip]
GO
GO
-- =============================================
-- Counties TABLE
-- =============================================
SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
CREATE TABLE [Counties](
[UID] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[CountyName] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[StateUID] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[SurTax] [money] NOT NULL
) ON [PRIMARY]';
my $regex = qr/CREATE TABLE \[.*\) ON \[PRIMARY\]/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}