import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"CREATE TABLE \[.*\) ON \[PRIMARY\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
CREATE TABLE [Company](
[CompanyName] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Address1] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Address2] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[City] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[State] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Zip] [numeric](18, 0) NOT NULL
) ON [PRIMARY]
GO
GO
SET ANSI_PADDING ON
GO
CREATE NONCLUSTERED INDEX [IX_Company] ON [Company]
(
[CompanyName] ASC
)WITH (PAD_INDEX = OFF, STATISTICS_NORECOMPUTE = OFF, SORT_IN_TEMPDB = OFF, DROP_EXISTING = OFF, ONLINE = OFF, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON, FILLFACTOR = 80) ON [PRIMARY]
GO
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_CompanyName] DEFAULT ('') FOR [CompanyName]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Address1] DEFAULT ('') FOR [Address1]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Address2] DEFAULT ('') FOR [Address2]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_City] DEFAULT ('') FOR [City]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_State] DEFAULT ('') FOR [State]
GO
ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Zip] DEFAULT ((0)) FOR [Zip]
GO
GO
-- =============================================
-- Counties TABLE
-- =============================================
SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
CREATE TABLE [Counties](
[UID] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[CountyName] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[StateUID] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[SurTax] [money] NOT NULL
) ON [PRIMARY]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)