import re
regex = re.compile(r"CREATE TABLE \[.*\) ON \[PRIMARY\]", flags=re.DOTALL)
test_str = ("CREATE TABLE [Company](\n"
" [CompanyName] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [Address1] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [Address2] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [City] [varchar](255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [State] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [Zip] [numeric](18, 0) NOT NULL\n"
") ON [PRIMARY]\n\n"
"GO\n\n"
"GO\n"
"SET ANSI_PADDING ON\n\n"
"GO\n"
"CREATE NONCLUSTERED INDEX [IX_Company] ON [Company]\n"
"(\n"
" [CompanyName] ASC\n"
")WITH (PAD_INDEX = OFF, STATISTICS_NORECOMPUTE = OFF, SORT_IN_TEMPDB = OFF, DROP_EXISTING = OFF, ONLINE = OFF, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON, FILLFACTOR = 80) ON [PRIMARY]\n"
"GO\n\n"
"GO\n"
"ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_CompanyName] DEFAULT ('') FOR [CompanyName]\n"
"GO\n"
"ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Address1] DEFAULT ('') FOR [Address1]\n"
"GO\n"
"ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Address2] DEFAULT ('') FOR [Address2]\n"
"GO\n"
"ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_City] DEFAULT ('') FOR [City]\n"
"GO\n"
"ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_State] DEFAULT ('') FOR [State]\n"
"GO\n"
"ALTER TABLE [Company] ADD CONSTRAINT [DF_Company_Zip] DEFAULT ((0)) FOR [Zip]\n"
"GO\n\n"
"GO\n\n"
"-- =============================================\n"
"-- Counties TABLE\n"
"-- =============================================\n"
"SET ANSI_NULLS ON\n"
"GO\n"
"SET QUOTED_IDENTIFIER ON\n"
"GO\n"
"CREATE TABLE [Counties](\n"
" [UID] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [CountyName] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [StateUID] [varchar](50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,\n"
" [SurTax] [money] NOT NULL\n"
") ON [PRIMARY]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")