const regex = /^(.*[ \-_])?(SS|SSN|SIN|SSIN|SSNSIN|((SOC(IAL)?[_\- ]?SEC(URITY)?|SOC)[_\-
]?(DISABILITY)?[_\- ]?(INSURANCE)?(NUMBER|NUM|NO|NBR|NR)?))([ \-_].*)?(?<!F)(?<!CD)(?<!DT)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*[ \\-_])?(SS|SSN|SIN|SSIN|SSNSIN|((SOC(IAL)?[_\\- ]?SEC(URITY)?|SOC)[_\\-
]?(DISABILITY)?[_\\- ]?(INSURANCE)?(NUMBER|NUM|NO|NBR|NR)?))([ \\-_].*)?(?<!F)(?<!CD)(?<!DT)$', 'gm')
const str = `anything_SSN_iRRELEVANTa;ldskf;lakjf;laskjfpoasiutpoasijh;alskd;afsd;alskfa;sldkj0928574 v09wy7 lkajhsgalkjshd
SSIN_okDT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}