$re = '/^(.*[ \-_])?(SS|SSN|SIN|SSIN|SSNSIN|((SOC(IAL)?[_\- ]?SEC(URITY)?|SOC)[_\-
]?(DISABILITY)?[_\- ]?(INSURANCE)?(NUMBER|NUM|NO|NBR|NR)?))([ \-_].*)?(?<!F)(?<!CD)(?<!DT)$/m';
$str = 'anything_SSN_iRRELEVANTa;ldskf;lakjf;laskjfpoasiutpoasijh;alskd;afsd;alskfa;sldkj0928574 v09wy7 lkajhsgalkjshd
SSIN_okDT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);