// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*[ \-_])?(SS|SSN|SIN|SSIN|SSNSIN|((SOC(IAL)?[_\- ]?SEC(URITY)?|SOC)[_\-
]?(DISABILITY)?[_\- ]?(INSURANCE)?(NUMBER|NUM|NO|NBR|NR)?))([ \-_].*)?(?<!F)(?<!CD)(?<!DT)$").unwrap();
let string = "anything_SSN_iRRELEVANTa;ldskf;lakjf;laskjfpoasiutpoasijh;alskd;afsd;alskfa;sldkj0928574 v09wy7 lkajhsgalkjshd
SSIN_okDT";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}