import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\D*(?:26|555))(?=(?:\\D*\\d){5}\\D*$)[\\d()-]{5,10}$";
final String string = "Valid inputs:\n"
+ "(12345)--\n"
+ "---12)567)\n"
+ "12333\n"
+ "-1-2--3-45\n"
+ "(()))12345\n"
+ "((12345\n"
+ "(-)65768-\n"
+ "(4)1-2-35\n\n"
+ "Invalid inputs:\n"
+ "26123---\n"
+ "(26)897---\n"
+ "-26333----\n"
+ "26\n"
+ "26(((())\n"
+ "26------\n"
+ "26--345\n"
+ "26)88-76\n"
+ "267-9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}