const regex = /(?<=\.Value\[)(?:{*)([^}]+)(?=[\]}])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.Value\\[)(?:{*)([^}]+)(?=[\\]}])', '')
const str = `{{server/Y2KCluster1:[]ServerServerStatusState}}.Value[{{{server/Y2KCluster2:[]ServerServerStatusSecondsTillShutdown}}}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}