re = /(?<=\.Value\[)(?:{*)([^}]+)(?=[\]}])/
str = '{{server/Y2KCluster1:[]ServerServerStatusState}}.Value[{{{server/Y2KCluster2:[]ServerServerStatusSecondsTillShutdown}}}]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end