package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)HTTP_TOKEN=(.+)&`)
var str = `https://website.com/?HTTP_TARGETPORTAL=7&HTTP_TOKEN=somedata&HSID_DOMAIN_URL=...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}