const regex = /(?<!function|var|new)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!function|var|new)\\s', 'gm')
const str = `function mFunct(variable){
var a, b, c;
new Class();
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}