re = /(?<!function|var|new)\s/m
str = 'function mFunct(variable){
var a, b, c;
new Class();
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end