$re = '/(?<!function|var|new)\s/m';
$str = 'function mFunct(variable){
var a, b, c;
new Class();
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);