import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "the";
final String string = "Here are some words: one, two, three, FOUR. \n"
+ "And here are some numbers: 1, 2, 3, 4, 10, 20, 30, 40, 100, 200, 300, 400, 1000. \n"
+ "Here are some mixed things: A1, A2, A3, A4\n"
+ "3 + 4 = 7\n"
+ "12 / 3 = 4\n"
+ "2 ^ 2 = 4\n\n"
+ "I think I've seen this film before\n"
+ "And I didn't like the ending\n"
+ "You're not my homeland anymore\n"
+ "So what am I defending now?\n"
+ "You were my town\n"
+ "Now I'm in exile, seein' you out\n"
+ "I think I've seen this film before\n\n"
+ " I can see you starin', honey\n"
+ "Like he's just your understudy\n"
+ "Like you'd get your knuckles bloody for me\n"
+ "Second, third, and hundredth chances\n"
+ "Balancin' on breaking branches\n"
+ "Those eyes add insult to injury";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}