// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)the").unwrap();
let string = "Here are some words: one, two, three, FOUR.
And here are some numbers: 1, 2, 3, 4, 10, 20, 30, 40, 100, 200, 300, 400, 1000.
Here are some mixed things: A1, A2, A3, A4
3 + 4 = 7
12 / 3 = 4
2 ^ 2 = 4
I think I've seen this film before
And I didn't like the ending
You're not my homeland anymore
So what am I defending now?
You were my town
Now I'm in exile, seein' you out
I think I've seen this film before
I can see you starin', honey
Like he's just your understudy
Like you'd get your knuckles bloody for me
Second, third, and hundredth chances
Balancin' on breaking branches
Those eyes add insult to injury";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}