using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(a|h1|p|title)[^>]*>([^<]+)</\1[^>]*>";
string input = @"<h1> content goeas here </h1>
<a href=""foo.html"">lmskdfg</a>
<title>qsdfqsdf</title>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}